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Before you start

* Before you start you will need to know the make and model of your labels, or the
size. Here are the standard sizes for A4 rectangular labels;

__

210mm x 297mm 63.5mm x 38.1mm
4 99.Tmm x 139mm 40 45.7mm x 25.4mm
8 99.1mm x 67.7mm 65 38.1mm x 21.2mm
12 63.5mm x 72mm 84 46mm x 11.1mm
14 99.1mm x 38.1mm
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How to create a page of labels C ]

Labels Format Options

Inscription

* Open OpenOffice Writer

* Select File>new>labels (e.g. Avery J8163) -

* Chose your label brand and type and select
sheet -

* Type in the label text _( )_ _—

* Go to the options tab and select Entire page 0 1
and Synchronise contents

* Click on New Document cm 1 ) Rew 1 3

* Edit and format the top left label, then click on JR—

Synchronise labels
e Save the document and print it.

Mendlesham Computer Club 4 NewDocument  Cancel  Hep Reset




How to create a page of labels in Word

* Go to Mailings > Labels.

AutoSave @ oFr

* Select Options and choose a label vendor and
product to use.

Home Insert Draw Design Layout References Mailings

. o M B [ B

* Type an address or other information in the Address Sl SRR Bl e e
box (text only).

* To change the formatting, select the text, right-click,
and make changes with Font or Paragraph.

* Select OK.
* Save the document and print it.

* NOTE. There is no ‘refresh’ ability in Word, you can
either open Mailings>Labels gain of copy and paste
all of the cells
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Mail-merge labels
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What is Mail-merge?

* Mail-merge fills values in a template document with names addresses or other data from a

database or list. For example to produce a page of address labels or a standard letter to many
recipients. B Ao Cperoriee o

]
File Edit View |Insert Format Tools Data Window Help
e F h BB H% 2 BER Y K- D @My HOEBEQ @ [ [V P
romt IS {8 |Aral | 110 VMBI Uls===84h%Y¥eB ecs 024
B9 vk E = IOwens
A [ D | E [ F [ G [ =
1 firstname lastname address1 address2 post_town postcode  county
| 2 Kimberly Johnson 16 North Park Mansfield NG18 4PA Nottinghamshire
' 3 Sydney  Farrell 1 Callander Close Fulwood PR29LP  Lancashire
4 |Henry Hall 12 Brookside Cleator CA23 3DU Cumbria 5
1010701\ Sheett (Shest2 [Shees /< 51
Sheet1/3 Default S |* Sum=0 Q=——F—0—0
Gabby Cass Nathan Mattie
62 Grove Road 67 Victoria Street
° 1 KIRKWALL CANTERBURY
TO th IS KW4 6VF CT98 6XH
Cary Everette Ralph Cassen
87 Grange Road 619 Manchester Road
YORK BRIGHTON
YO16 9KP BN29 9PT
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What is Mail-merge?

* The simplest database starts with a spreadsheet with the names of the fields in the
first row.

) Addresses.sxc - OpenOffice Calc a =
File Edit View |Insert Format Tools Data Window Help
B-2-H2 2 BEaR YE Xee-¢ D @8k H2EE8Q 0 4 X
‘B | Arial v| |10 v B/ U s===sH ¥R cE0-2-4-

B9 vi Kk E = IOwens

A e c I D l E | F | G |~

1 [firsthname lastname address1 address?2 post_town postcode  county

2 [Kimberly Johnson 16 North Park Mansfield NG18 4PA Nottinghamshire

3 Sydney Farrell 1 Callander Close Fulwood PR29LP Lancashire

4 |Henry Hall 12 Brookside Cleator CA23 3DU Cumbria ;
< v 71 Sheet1 / Sheet2 { Sheet3 / 1< >|
Sheet1/3 | Default \ |so |*]| | Sum=0 @ ——F——0
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Preparing the data source - 1

A B C D E
1 First_name Last_name Address_1 Address_2 Postcode
2 Gabby Cass 62 Grove Road KIRKWALL KW4 6VF

* Create a spreadsheet with the field names as the first row
— Do not include spaces in fieldnames, use _ instead to make them more readable
— Do not start them with a number e.g. instead of 1address use address_1

— Rename the sheet from Sheetl to something more useful (optional)
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Save the spreadsheet

In OpenOffice

* Save the file as a .sxc format, there is an example here;
https://godartbrowncom.ipage.com/MCC/docs/examples/OpenOffice/address book demo.sxc

In Microsoft Excel

* Save the spreadsheet as usual

Mendlesham Computer Club 10


https://godartbrowncom.ipage.com/MCC/docs/examples/OpenOffice/address_book_demo.sxc

Open Office instructions

Mendlesham Computer Club By Giles Godart-Brown



Preparing the data source in OpenOffice

@ Database Wizard | @
| Steps Welcome to the OpenOffice Database Wizard | Steps
' 1. Select database Use the Database Wizard to create a new database, open an existing database 1. Select database

| 2.Set up Spreadsheet file, or connect to a database stored on a server.

> 2. Set up Spreadsheet
connection

connection
| 3-Save and proceed 3. Save and proceed
What do you want to do?
Create a new database
Open an existing database file

Recently used

Open...

© Connect to an existing database

Spreadsheet :

Database Wizard

Set up a cor ion to spreadsh

Click 'Browse...' to select a OpenOffice spreadsheet or Microsoft Excel workbook.
OpenOffice will open this file in read-only mode.

Location and file name

/Users/gilesGB/temp/address_book_demo.sxc _

Password required

* Turn this into a database that the writer can use as a source
— Stay in calc and do File>New database

— Select connect to an existing database and chose spreadsheet

— Click next and chose the name of the spreadsheet you just created, next, save the file as an .odb and finish

— You can close the window it then opens
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Merging the source into labels in OpenOffice

Open OpenOffice writer and select

File->New->Labels

On the Labels tab

Select the database you just created and the table name
(the name of the workbook — default is Sheet1)

For each database field you want on the label, click the
arrow to copy it over to the label text box, don’t forget to
add spaces, returns and other text

Check synchronise labels on the Options page
as before

Click on New document
You wont see the actual data, only the field names
Then edit as before and hit print

Select yes when it asks if you are printing a form letter
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'® Labels |

Labels Format Options

Inscription
Label text Address Database
k_database.Addresses.0.First_name> address book database
k_database.Addresses.0.Last_name> — —
k_database.Addresses.0.Address_1> Table
k_database.Addresses.0.Address_2>
k_database.Addresses.0.Postcode> Addresses
. i
Database field [
- Postcode I
l
Format
Continuous Brand Avery A4
O Sheet Type J8163 Address

J8163 Address: 9.91 cm x 3.81 cm (2 x 7)
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Printing the labels in OpenOffice

* On the popup that appears
— Select All if you want all of the

addresses included, otherwise just

chose the rows you want

— Select file to create a new document
containing all of the labels, otherwise
select printer and they will print to

your printer
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i @ @ Mail Merge
; By h S 188 KTy =i
{ & address bool First_name Last_name Address_1 Address_2 Postcode
1 (=] Queries » |Gabby Cass 62 Grove Road KIRKWALL KW4 6VF
! Tables Nathan Mattie 67 Victoria Stre CANTERBURY CT98 6XH
j =] Sheetl Cary Everette 87 Grange Roa YORK YO16 9KP
| & address Datal Ralph Cassen 619 Mancheste BRIGHTON  BN29 9PT
- Kody Kallah 41 New Street TELFORD TF66 7MG
Record [1 [ of 10 an
Records Output
O Al © Printer File
Selected records
SOl 1 To: 1 Save merged document
1 Save as single document
Save as individual documents
Generate file name from Database

Field First_name

Path /Users/gilesGB/Documents

File format ODF Text Document
|
>Flll K b o T TT=T




Microsoft Office instructions
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Create labels and attach your spreadsheet to the document

* Save your spreadsheet as usual

* Create a new document in Word

* Select Mailings>Labels

* Chose the correct label format (Avery A4/A5 J8163) and click OK

* Chose Select recipients>Use an existing list and browse to your spreadsheet and click Open
* Don’t worry that all the cells contain <<next record>> except the first one

* Put your cursor in the top left box and click on Insert Merge field to copy the field you want to the page,
add any spaces or returns and repeat for all of the fields you want, then add any formatting you need.

* Click on Update labels to copy the formatted fields to the remaining cells
* Click on Preview Results to see what it will look like with the data filled in

* When its OK, click on Finish and merge to either print directly or create a file containing the final
document.
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Creating a Mail-merge letter
in OpenOffice
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Create a mail-merge letter in OpenOffice - 1

There is a Mail-merge wizard, but OpenOffice does not recommend you use it, instead follow the
steps below.

1. Prepare the database as before
2. Start to create your document with gaps for the fields you have in your database

3. Select View>Data sources and select the database and table you created earlier

&l address_book_database First_name Last_name Address_1 Address_2 Postcode
(=] Queries > |Gabby Cass 62 Grove Roac KIRKWALL  KW4 6VF
(5 Tables Nathan Mattie 67 Victoria Stre CANTERBURY CT98 6XH
= fj\'&&;éééé's;i Cary Everette 87 Grange Roz YORK YO16 9KP
43:’3 Biblioaraphy Ralph Cassen 619 Mancheste BRIGHTON  BN29 9PT
graphy Kody Kallah 41 New Street TELFORD  TF66 7MG
Alfred Katie 50 Richmond F COLCHESTEFR CO32 6TA
Record [1 | of 10 Bn
L ...1... .1*.23-3.-L4.§-.6J-.7.L8.L9.19.11
~ Dear
) Thanks
o Giles
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Create a mail-merge letter in OpenOffice - 2

4. Drag and drop the column headings to where you want them to appear on your letter

/=l address_book_database First_ name = Last_name = Address_1 = Address_2 = Postcode
(=] Queries > |Gabby Cass 62 Grove Roac KIRKWALL  KW4 6VF
Tables Nathan Mattie 67 Victoria Stre CANTERBURY CT98 6XH

Cary Everette 87 Grange Roz YORK YO16 9KP
Add
@ B'b hresses Ralph Cassen 619 Mancheste BRIGHTON  BN29 9PT
follograpny Kody Kallah 41 New Street TELFORD  TF66 7TMG
Alfred Katie 50 Richmond F COLCHESTEF CO32 6TA
Record [1 | of 10 rom
-~ "'1'"E'"1j."2'3.'3"j.4'"53."'6';"7"4.'8"}.9"'19"

<Address_1>
<Address_2>
<Postcode>|

Dear <First_name> <Last_name>
Thanks
Giles
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Create a mail-merge letter in OpenOffice - 3

@® OpenOffice 4.1.7

0 Your document contains address database fields. Do you want to print a form |

5. Select File>Print to either print the eter
e Mo hep

document or create a new document
containing the merged information — you e

Wi I I S e e a W a r n i n g t h at t h e d O C u m e n t é; address_book_ First_name Last_name Address_1 Address_2 Postcode

(=1 Queries Gabby Cass 62 Grove Roac KIRKWALL KW4 6VF

[ Tables Nathan Mattie 67 Victoria Stre CANTERBURY CT98 6XH

a
1 1 1 Cary Everette 87 Grange Roz YORK YO16 9KP
=] Address |—
contains database fields, click Yes. s | EN Gy awmeneoROTON SN o
follography Kody Kallah 41 New Street TELFORD  TF66 7TMG
Record [1 | of 10 1]
Records Output
O Al Printer © File
Selected records
From: 1 To: 1

Save merged document

© Save as single document

6. If you select file, you can create a single

file containing all of the letters or one
(6{0) ntaining them a” Path IUsers/gilesGB/Documents

File format ODF Text Document

. Ok Cancel  Hep
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Creating a Mail-merge letter in
Microsoft Office
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Caveat

NOTE: Microsoft has changed the way this works over the years
and it may be slightly different in your version.
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Preparing the data source

A B C D E
1 First_name Last_name Address_1 Address_2 Postcode
2 Gabby Cass 62 Grove Road KIRKWALL KW4 6VF

* Create a spreadsheet in Excel with the field names as the first row
— Do not include spaces in fieldnames, use _ instead to make them more readable
— Do not start them with a number e.g. instead of 1address use address_1
— Rename the sheet from Sheetl to something more useful (optional)

— Save the file normally
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Creating your merge document

1 ) C re ate yo u r d O C u m e nt a S n o rm a I Home lnsra E Degn Layout feces Mailings Review  View sz Oc
2. Click on the Mailings tab chose =28 [ % P B | B i _
i pes Labels St"jretrgﬁ:ll ' N Rules Ltpga‘ie lerein\gz Find Recipient To rwsg &
DeSIgn>Use an eXlStlng Ilst r lé:eanixistinogl;:st.i(.c - ‘4 5‘ 6 : 7 ‘ 8 ‘9 10‘ 11 ‘ 12 ‘13 ll4 15‘ 6 17 18
. | [8 Apple Contacts...
3. Navigate to your spreadsheet and accept the [ FilakerPro..
defaults

4. Optionally add a filter if you don’t want the whole list to get the letter

AutoSave @ orF

5. Navigate in your document to where you want the

Home Insert Draw  Design Layout References  Mailings Review  View

merged field and select Mailings>Insert Merge Field and ;
g ) ] g g E Flg l_@]" '?prc‘z“ @ g8 ¥ D’?" ABC
chose the field to insert. Suliso WS Tl eeel el W s
P 2 1 >\/ 1 . Last_name
6. Optionally preview the results | Aadresst

Postcode

7. Finally chose Mailings>Finish & Merge>Edit individual documents.
This will produce an individual document for each recipient.
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